Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1636880 - (CVE-2018-14661) CVE-2018-14661 glusterfs: features/locks translator passes an user-controlled string to snprintf without a proper format string resulting in a denial of service
CVE-2018-14661 glusterfs: features/locks translator passes an user-controlled...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20181031:0800,...
: Security
Depends On: 1644578 1644763 1647666 1647668 1616829 1637084
Blocks: 1636883 1644080
  Show dependency treegraph
 
Reported: 2018-10-08 03:55 EDT by Andrej Nemec
Modified: 2018-11-08 00:18 EST (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
It was found that usage of snprintf function in feature/locks translator of glusterfs server was vulnerable to a format string attack. A remote, authenticated attacker could use this flaw to cause remote denial of service.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3431 None None None 2018-10-31 04:43 EDT
Red Hat Product Errata RHSA-2018:3432 None None None 2018-10-31 04:45 EDT
Red Hat Product Errata RHSA-2018:3470 None None None 2018-11-05 09:59 EST

  None (edit)
Description Andrej Nemec 2018-10-08 03:55:05 EDT
A vulnerability was found in Gluster's features/locks translator An user-controlled string is given to snprintf without a proper format string. Sending a specially crafted string would result in a denial of service.
Comment 1 Andrej Nemec 2018-10-08 03:55:17 EDT
Acknowledgments:

Name: Michael Hanselmann (hansmi.ch)
Comment 4 Doran Moppert 2018-10-10 20:10:51 EDT
Statement:

This issue did not affect Red Hat Enterprise Linux 6 and 7 as the flaw is present in glusterfs-server, which is not shipped there.

This flaw affects glusterfs versions included in Red Hat Virtualization 4 Hypervisor. However, in recommended configurations, the vulnerability is only exposed to hypervisor administrators and can not be exploited from virtual machines or other hosts on the network.
Comment 5 Siddharth Sharma 2018-10-31 04:11:57 EDT
Created glusterfs tracking bugs for this issue:

Affects: fedora-all [bug 1644578]
Comment 6 errata-xmlrpc 2018-10-31 04:43:42 EDT
This issue has been addressed in the following products:

  Red Hat Gluster Storage 3.4 for RHEL 6
  Native Client for RHEL 6 for Red Hat Storage

Via RHSA-2018:3431 https://access.redhat.com/errata/RHSA-2018:3431
Comment 7 errata-xmlrpc 2018-10-31 04:44:50 EDT
This issue has been addressed in the following products:

  Red Hat Gluster Storage 3.4 for RHEL 7
  Native Client for RHEL 7 for Red Hat Storage

Via RHSA-2018:3432 https://access.redhat.com/errata/RHSA-2018:3432
Comment 8 Siddharth Sharma 2018-11-01 01:22:06 EDT
upstream fix:

https://review.gluster.org/#/c/glusterfs/+/21532/
Comment 9 errata-xmlrpc 2018-11-05 09:58:59 EST
This issue has been addressed in the following products:

  Red Hat Virtualization 4 for Red Hat Enterprise Linux 7

Via RHSA-2018:3470 https://access.redhat.com/errata/RHSA-2018:3470

Note You need to log in before you can comment on or make changes to this bug.