Bug 1696112 (CVE-2018-18497) - CVE-2018-18497 firefox: WebExtensions can load arbitrary URLs through pipe separators
Summary: CVE-2018-18497 firefox: WebExtensions can load arbitrary URLs through pipe se...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2018-18497
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1692767
TreeView+ depends on / blocked
 
Reported: 2019-04-04 07:44 UTC by msiddiqu
Modified: 2019-09-29 15:10 UTC (History)
11 users (show)

Fixed In Version: firefox 64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-05 03:13:11 UTC


Attachments (Terms of Use)

Description msiddiqu 2019-04-04 07:44:35 UTC
Limitations on the URIs allowed to WebExtensions by the browser.windows.create API can be bypassed when a pipe in the URL field is used within the extension to load multiple pages as a single argument. This could allow a malicious WebExtension to open privileged about: or file: locations. This vulnerability affects Firefox < 64.

External References: 
https://www.mozilla.org/en-US/security/advisories/mfsa2018-29/#CVE-2018-18497

References: 
https://bugzilla.mozilla.org/show_bug.cgi?id=1488180


Note You need to log in before you can comment on or make changes to this bug.