Bug 1647043 (CVE-2018-18751) - CVE-2018-18751 gettext: double free in default_add_message in read-catalog.c
Summary: CVE-2018-18751 gettext: double free in default_add_message in read-catalog.c
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-18751
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1648433 1647044 1647045 1647047 1647049 1647050
Blocks: 1647046
TreeView+ depends on / blocked
 
Reported: 2018-11-06 15:20 UTC by Laura Pardo
Modified: 2019-11-06 00:51 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 00:51:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:3643 None None None 2019-11-05 21:23:46 UTC

Description Laura Pardo 2018-11-06 15:20:39 UTC
An issue was discovered in GNU gettext 0.19.8. There is a double free in default_add_message in read-catalog.c, related to an invalid free in po_gram_parse in po-gram-gen.y, as demonstrated by lt-msgfmt. 


References:
https://github.com/CCCCCrash/POCs/tree/master/Bin/Tools-gettext-0.19.8.1/doublefree 
https://github.com/CCCCCrash/POCs/tree/master/Bin/Tools-gettext-0.19.8.1/heapcorruption

Comment 1 Laura Pardo 2018-11-06 15:21:52 UTC
Created gettext tracking bugs for this issue:

Affects: fedora-all [bug 1647044]


Created mingw-gettext tracking bugs for this issue:

Affects: epel-7 [bug 1647045]
Affects: fedora-all [bug 1647047]

Comment 4 Stefan Cornelius 2018-11-09 17:41:01 UTC
Statement:

This issue affects the versions of gettext as shipped with Red Hat Enterprise Linux 7.

This issue did not affect the versions of gettext as shipped with Red Hat Enterprise Linux 5 and 6.

Comment 7 errata-xmlrpc 2019-11-05 21:23:45 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2019:3643 https://access.redhat.com/errata/RHSA-2019:3643

Comment 8 Product Security DevOps Team 2019-11-06 00:51:25 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-18751


Note You need to log in before you can comment on or make changes to this bug.