Bug 1661465 (CVE-2018-19871) - CVE-2018-19871 qt5-qtimageformats: QTgaFile CPU exhaustion
Summary: CVE-2018-19871 qt5-qtimageformats: QTgaFile CPU exhaustion
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-19871
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20180824,reported=2...
Depends On: 1661467 1661468 1661469 1667879 1667883 1661466 1667881
Blocks: 1661470
TreeView+ depends on / blocked
 
Reported: 2018-12-21 10:14 UTC by Andrej Nemec
Modified: 2019-08-06 13:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:21:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:2135 None None None 2019-08-06 12:18:49 UTC

Description Andrej Nemec 2018-12-21 10:14:42 UTC
A TGA handler of QT imageformats incorrectly checks for large image sizes. A malformed image file could cause CPU exhaustion and denial of service.

References:

https://codereview.qt-project.org/#/c/237761/

Comment 1 Andrej Nemec 2018-12-21 10:14:59 UTC
Created mingw-qt5-qtimageformats tracking bugs for this issue:

Affects: epel-7 [bug 1661469]
Affects: fedora-all [bug 1661466]


Created qt5-qtimageformats tracking bugs for this issue:

Affects: epel-6 [bug 1661468]
Affects: fedora-all [bug 1661467]

Comment 2 Stefan Cornelius 2019-01-23 12:51:16 UTC
Statement:

This issue affects the versions of qt5-qtimageformats and qt as shipped with Red Hat Enterprise Linux 7.

Comment 3 errata-xmlrpc 2019-08-06 12:18:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2019:2135 https://access.redhat.com/errata/RHSA-2019:2135

Comment 4 Product Security DevOps Team 2019-08-06 13:21:09 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-19871


Note You need to log in before you can comment on or make changes to this bug.