Bug 1665582 (CVE-2018-20430) - CVE-2018-20430 libextractor: out-of-bounds read vulnerability in history_extract in plugins/ole2_extractor.c
Summary: CVE-2018-20430 libextractor: out-of-bounds read vulnerability in history_extr...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2018-20430
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1665583
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 20:33 UTC by Laura Pardo
Modified: 2019-09-29 15:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:45:13 UTC


Attachments (Terms of Use)

Description Laura Pardo 2019-01-11 20:33:04 UTC
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.


References:
https://gnunet.org/bugs/view.php?id=5493
https://gnunet.org/git/libextractor.git/tree/ChangeLog

Upstream Patch:
https://gnunet.org/git/libextractor.git/commit/?id=b405d707b36e0654900cba78e89f49779efea110

Comment 1 Laura Pardo 2019-01-11 20:33:18 UTC
Created libextractor tracking bugs for this issue:

Affects: fedora-all [bug 1665583]

Comment 2 Product Security DevOps Team 2019-06-10 10:45:13 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.