Bug 1900854 (CVE-2018-20805) - CVE-2018-20805 mongodb: Denial of service via crafted queries which perform an $elemMatch
Summary: CVE-2018-20805 mongodb: Denial of service via crafted queries which perform a...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2018-20805
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1900856
Blocks: 1900872
TreeView+ depends on / blocked
 
Reported: 2020-11-23 20:47 UTC by Pedro Sampaio
Modified: 2021-02-13 00:09 UTC (History)
26 users (show)

Fixed In Version: mongodb 3.6.13, mongodb 4.0.10, mongodb 4.1.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-04 23:03:00 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2020-11-23 20:47:37 UTC
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which perform an $elemMatch This issue affects: MongoDB Inc. MongoDB Server v4.0 versions prior to 4.0.5; v3.6 versions prior to 3.6.10. This issue affects: MongoDB Inc. MongoDB Server 3.6 versions prior to 3.6.10; 4.0 versions prior to 4.0.5.

Upstream bug:

https://jira.mongodb.org/browse/SERVER-38164

Comment 1 Pedro Sampaio 2020-11-23 20:48:18 UTC
Created mongodb tracking bugs for this issue:

Affects: epel-all [bug 1900856]

Comment 2 Yadnyawalk Tale 2020-11-30 17:38:18 UTC
Red Hat Satellite 6.6 onward does not ship the MongoDB package; however, the product consumes MongoDB from Red Hat Software Collections (RHSCL) for Red Hat Enterprise Linux. Satellite has no plans to update to a version of MongoDB released with a Server Side Public License (SSPL) which includes all versions released after October 16, 2018. Refer to this article for more information: https://access.redhat.com/articles/5767021

Comment 3 Riccardo Schirone 2020-12-01 10:35:35 UTC
Upstream patch:
https://github.com/mongodb/mongo/commit/94d0e046baa64d1aa1a6af97e2d19bb466cc1ff5

Comment 4 Product Security DevOps Team 2020-12-04 23:03:00 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-20805


Note You need to log in before you can comment on or make changes to this bug.