Bug 1956927 (CVE-2018-25014) - CVE-2018-25014 libwebp: use of uninitialized value in ReadSymbol()
Summary: CVE-2018-25014 libwebp: use of uninitialized value in ReadSymbol()
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-25014
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1961979 1962004 1962005 1961614 1961615 1961677 1961678 1961679 1961680 1961681 1961742 1961978
Blocks: 1940150 1956995
TreeView+ depends on / blocked
 
Reported: 2021-05-04 16:46 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-04-17 21:22 UTC (History)
10 users (show)

Fixed In Version: libwebp 1.0.1
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in libwebp. An unitialized variable is used in function ReadSymbol. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-06-09 03:04:05 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:2328 0 None None None 2021-06-08 22:38:24 UTC
Red Hat Product Errata RHSA-2021:4231 0 None None None 2021-11-09 17:50:37 UTC

Description Guilherme de Almeida Suckevicz 2021-05-04 16:46:09 UTC
A use of uninitialized value was found in libwebp in versions before 1.0.1 in ReadSymbol().

Reference:
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9496

Comment 9 errata-xmlrpc 2021-06-08 22:38:22 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:2328 https://access.redhat.com/errata/RHSA-2021:2328

Comment 10 Product Security DevOps Team 2021-06-09 03:04:05 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-25014

Comment 11 errata-xmlrpc 2021-11-09 17:50:35 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4231 https://access.redhat.com/errata/RHSA-2021:4231


Note You need to log in before you can comment on or make changes to this bug.