Bug 1532573 (CVE-2018-5205) - CVE-2018-5205 irssi: Out-of-bounds read when using incomplete escape codes
Summary: CVE-2018-5205 irssi: Out-of-bounds read when using incomplete escape codes
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2018-5205
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1532625 1532626
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-09 11:28 UTC by Adam Mariš
Modified: 2021-02-17 01:00 UTC (History)
2 users (show)

Fixed In Version: irssi 1.0.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 03:36:36 UTC


Attachments (Terms of Use)

Description Adam Mariš 2018-01-09 11:28:05 UTC
When using incomplete escape codes, Irssi may access data beyond the end of the string.

The exploitation of the issue requires user to install malicious or broken files or enter affected commands.

Comment 1 Adam Mariš 2018-01-09 11:28:32 UTC
External References:

https://irssi.org/security/irssi_sa_2018_01.txt

Comment 2 Adam Mariš 2018-01-09 13:17:49 UTC
Created irssi tracking bugs for this issue:

Affects: fedora-all [bug 1532625]


Note You need to log in before you can comment on or make changes to this bug.