Bug 1588925 (CVE-2018-6515) - CVE-2018-6515 puppet-agent: pxp-agent attempts to configure OpenSSL from uncontrolled location
Summary: CVE-2018-6515 puppet-agent: pxp-agent attempts to configure OpenSSL from unco...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-6515
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-08 06:48 UTC by Adam Mariš
Modified: 2019-09-29 14:41 UTC (History)
9 users (show)

Fixed In Version: puppet-agent 1.10.13, puppet-agent 5.3.7, puppet-agent 5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-08 06:55:53 UTC


Attachments (Terms of Use)

Description Adam Mariš 2018-06-08 06:48:46 UTC
On Windows only, with a specially crafted configuration file an attacker could get pxp-agent to load arbitrary code with privilege escalation.

External References:

https://puppet.com/security/cve/CVE-2018-6515

Comment 1 Adam Mariš 2018-06-08 06:55:59 UTC
Statement:

This issue did not affect the versions of puppet-agent as shipped with Red Hat Satellite 6 as this issue is specific to Windows platform only.


Note You need to log in before you can comment on or make changes to this bug.