Bug 1549308 (CVE-2018-7419) - CVE-2018-7419 wireshark: NBAP dissector crash in nbap.cnf
Summary: CVE-2018-7419 wireshark: NBAP dissector crash in nbap.cnf
Status: CLOSED NOTABUG
Alias: CVE-2018-7419
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20180218,reported=2...
Keywords: Security
Depends On: 1549309
Blocks: 1549310
TreeView+ depends on / blocked
 
Reported: 2018-02-26 22:46 UTC by Laura Pardo
Modified: 2019-06-08 22:42 UTC (History)
8 users (show)

(edit)
A denial of service flaw was found in the NBAP dissector in Wireshark. A remote network attacker could potentially use this flaw to crash Wireshark by tricking it into processing a crafted packet.
Clone Of:
(edit)
Last Closed: 2018-03-16 08:05:23 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-02-26 22:46:24 UTC
A flaw was found in Wireshark 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4, the NBAP dissector could crash. This was addressed in epan/dissectors/asn1/nbap/nbap.cnf by ensuring DCH ID initialization. 

External References:

https://www.wireshark.org/security/wnpa-sec-2018-14.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14443

Upstream Patch:

https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=bebd3a1f50b0a2

Comment 1 Laura Pardo 2018-02-26 22:47:42 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1549309]


Note You need to log in before you can comment on or make changes to this bug.