Bug 1692755 (CVE-2019-0204) - CVE-2019-0204 mesos: docker image code execution
Summary: CVE-2019-0204 mesos: docker image code execution
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-0204
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1692756
Blocks: 1692758
TreeView+ depends on / blocked
 
Reported: 2019-03-26 11:26 UTC by Dhananjay Arunesh
Modified: 2020-12-15 15:43 UTC (History)
3 users (show)

Fixed In Version: Apache Mesos 1.4.3, Apache Mesos 1.5.3, Apache Mesos 1.6.2, Apache Mesos 1.7.2, Apache Mesos 1.8.0
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Docker image running under root user, where it is possible to overwrite the init helper binary of the container runtime or the command executor in Apache Mesos. A malicious user could use this flaw to gain root-level code execution on the host.
Clone Of:
Environment:
Last Closed: 2019-11-15 00:51:22 UTC
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:3892 0 None None None 2019-11-14 21:18:28 UTC

Description Dhananjay Arunesh 2019-03-26 11:26:13 UTC
A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.

Reference:
https://lists.apache.org/thread.html/b162dd624dc088cd634292f0402282a1d1d0ce853baeae8205bc033c@%3Cdev.mesos.apache.org%3E

Comment 1 Dhananjay Arunesh 2019-03-26 11:26:23 UTC
Created mesos tracking bugs for this issue:

Affects: fedora-all [bug 1692756]

Comment 3 errata-xmlrpc 2019-11-14 21:18:27 UTC
This issue has been addressed in the following products:

  Red Hat Fuse 7.5.0

Via RHSA-2019:3892 https://access.redhat.com/errata/RHSA-2019:3892

Comment 4 Product Security DevOps Team 2019-11-15 00:51:22 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-0204


Note You need to log in before you can comment on or make changes to this bug.