Bug 1719698 (CVE-2019-10164) - CVE-2019-10164 PostgreSQL: stack-based buffer overflow via setting a password
Summary: CVE-2019-10164 PostgreSQL: stack-based buffer overflow via setting a password
Keywords:
Status: NEW
Alias: CVE-2019-10164
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20190620,repor...
Depends On: 1727802 1727803 1727804 1727805 1728128 1723412 1723413 1723414
Blocks: 1719701
TreeView+ depends on / blocked
 
Reported: 2019-06-12 11:21 UTC by msiddiqu
Modified: 2019-08-20 06:20 UTC (History)
53 users (show)

Fixed In Version: PostgreSQL 10.9, PostgreSQL 11.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description msiddiqu 2019-06-12 11:21:50 UTC
Any authenticated user can overflow a stack-based buffer by changing the
user's own password to a purpose-crafted value. This often suffices to
execute arbitrary code as the PostgreSQL operating system account.

Comment 1 msiddiqu 2019-06-24 13:11:01 UTC
External References:

https://www.postgresql.org/support/security/

Comment 2 msiddiqu 2019-06-24 13:26:41 UTC
Created mingw-postgresql tracking bugs for this issue:

Affects: epel-7 [bug 1723414]
Affects: fedora-all [bug 1723412]


Created postgresql tracking bugs for this issue:

Affects: fedora-all [bug 1723413]


Note You need to log in before you can comment on or make changes to this bug.