Bug 1719494 (CVE-2019-11027) - CVE-2019-11027 rubygem-ruby-openid: Unknown remotely exploitable flaw
Summary: CVE-2019-11027 rubygem-ruby-openid: Unknown remotely exploitable flaw
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2019-11027
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1719495
Blocks: 1811129
TreeView+ depends on / blocked
 
Reported: 2019-06-11 23:59 UTC by Pedro Sampaio
Modified: 2020-03-06 16:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-12 13:07:35 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2019-06-11 23:59:12 UTC
Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.

Upstream issue:

https://github.com/openid/ruby-openid/issues/122

References:

https://marc.info/?l=openid-security&m=155154717027534&w=2

Comment 1 Pedro Sampaio 2019-06-11 23:59:25 UTC
Created rubygem-ruby-openid tracking bugs for this issue:

Affects: fedora-29 [bug 1719495]


Note You need to log in before you can comment on or make changes to this bug.