Bug 1708570 (CVE-2019-11037) - CVE-2019-11037 php-imagick: out-of-bounds write to memory in ImagickKernel::fromMatrix() leading to possible crash and DoS
Summary: CVE-2019-11037 php-imagick: out-of-bounds write to memory in ImagickKernel::f...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2019-11037
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1708571
Blocks: 1708572
TreeView+ depends on / blocked
 
Reported: 2019-05-10 08:53 UTC by Marian Rehak
Modified: 2019-09-29 15:13 UTC (History)
10 users (show)

Fixed In Version: php-imagick 3.4.4RC1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:55:20 UTC


Attachments (Terms of Use)

Description Marian Rehak 2019-05-10 08:53:00 UTC
An out-of-bounds write to memory has been found in PHP imagick extension versions between 3.3.0 - 3.4.4 in function ImagickKernel::fromMatrix() leading to possible crash and DoS.

Upstream bug:

https://bugs.php.net/bug.php?id=77791

Comment 1 Marian Rehak 2019-05-10 08:53:36 UTC
Created php-pecl-imagick tracking bugs for this issue:

Affects: fedora-all [bug 1708571]

Comment 4 Sam Fowler 2019-05-12 23:55:22 UTC
Statement:

This vulnerability does not affect the php55-php-pecl-imagick package shipped in OpenShift Container Platform 3.4 as it does not contain the vulnerable code. The vulnerable source file, imagickkernel_class.c, was added to php-imagick in version 3.3.0. OpenShift Container Platform ships version 3.1.2 and does not contain this source file.


Note You need to log in before you can comment on or make changes to this bug.