Bug 1757701 (CVE-2019-11253) - CVE-2019-11253 kubernetes: YAML parsing vulnerable to "Billion Laughs" attack, allowing for remote denial of service
Summary: CVE-2019-11253 kubernetes: YAML parsing vulnerable to "Billion Laughs" attack...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-11253
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1757702 1757711 1757708 1757709 1757710 1757712 1757887
Blocks: 1757703
TreeView+ depends on / blocked
 
Reported: 2019-10-02 08:41 UTC by Sam Fowler
Modified: 2019-12-10 01:17 UTC (History)
36 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 18:51:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3820 None None None 2019-11-11 09:57:43 UTC
Red Hat Product Errata RHBA-2019:3907 None None None 2019-11-18 21:44:14 UTC
Red Hat Product Errata RHBA-2019:4059 None None None 2019-12-03 08:51:15 UTC
Red Hat Product Errata RHBA-2019:4122 None None None 2019-12-10 01:17:47 UTC
Red Hat Product Errata RHSA-2019:3132 None None None 2019-10-16 15:36:09 UTC
Red Hat Product Errata RHSA-2019:3239 None None None 2019-10-29 16:21:26 UTC
Red Hat Product Errata RHSA-2019:3811 None None None 2019-11-07 16:54:28 UTC
Red Hat Product Errata RHSA-2019:3905 None None None 2019-11-18 16:22:00 UTC

Description Sam Fowler 2019-10-02 08:41:11 UTC
The parsing of YAML manifests by the Kubernetes API server could lead to a denial-of-service attack against a cluster’s Kubernetes API service, therefore leaving it vulnerable to an instance of a “billion laughs” attack.


Upstream Issue:

https://github.com/kubernetes/kubernetes/issues/83253


Reference:

https://www.stackrox.com/post/2019/09/protecting-kubernetes-api-against-cve-2019-11253-billion-laughs-attack/

Comment 1 Sam Fowler 2019-10-02 08:41:28 UTC
Created kubernetes tracking bugs for this issue:

Affects: fedora-all [bug 1757702]

Comment 11 errata-xmlrpc 2019-10-16 15:36:06 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.1

Via RHSA-2019:3132 https://access.redhat.com/errata/RHSA-2019:3132

Comment 12 Product Security DevOps Team 2019-10-16 18:51:20 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-11253

Comment 15 errata-xmlrpc 2019-10-29 16:21:22 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.10

Via RHSA-2019:3239 https://access.redhat.com/errata/RHSA-2019:3239

Comment 17 errata-xmlrpc 2019-11-07 16:54:26 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.9

Via RHSA-2019:3811 https://access.redhat.com/errata/RHSA-2019:3811

Comment 18 errata-xmlrpc 2019-11-18 16:21:58 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2019:3905 https://access.redhat.com/errata/RHSA-2019:3905


Note You need to log in before you can comment on or make changes to this bug.