Bug 1772523 (CVE-2019-14889) - CVE-2019-14889 libssh: unsanitized location in scp could lead to unwanted command execution
Summary: CVE-2019-14889 libssh: unsanitized location in scp could lead to unwanted com...
Keywords:
Status: NEW
Alias: CVE-2019-14889
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1781781 1781782 1781780
Blocks: 1772524
TreeView+ depends on / blocked
 
Reported: 2019-11-14 14:50 UTC by Marian Rehak
Modified: 2020-05-18 12:22 UTC (History)
17 users (show)

Fixed In Version: libssh 0.9.3, libssh 0.8.8
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found with the libssh API function ssh_scp_new(). A user able to connect to a server using SCP could execute arbitrary command using a user-provided path, leading to a compromise of the remote target.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Marian Rehak 2019-11-14 14:50:47 UTC
When the libssh SCP client connects to a server, the scp command, which includes a user-provided path, is executed on the server-side. In case the library is used in a way where users can influence the third parameter of ssh_scp_new(), it would become possible for an attacker to inject arbitrary commands, leading to a compromise of the remote target.

Comment 1 Huzaifa S. Sidhpurwala 2019-11-24 12:58:21 UTC
Upstream bug: https://bugs.libssh.org/T181

Comment 2 Huzaifa S. Sidhpurwala 2019-12-10 15:11:32 UTC
Acknowledgments:

Name: libssh project
Upstream: Cure53

Comment 3 Huzaifa S. Sidhpurwala 2019-12-10 15:11:36 UTC
External References:

https://www.libssh.org/security/advisories/CVE-2019-14889.txt

Comment 4 Huzaifa S. Sidhpurwala 2019-12-10 15:12:31 UTC
Created libssh tracking bugs for this issue:

Affects: epel-all [bug 1781781]
Affects: fedora-all [bug 1781780]

Comment 7 Doran Moppert 2019-12-17 03:10:11 UTC
Statement:

Red Hat Virtualization only uses libssh for client-side, not server-side where this vulnerability is present.

Comment 8 Andreas Schneider 2019-12-17 08:10:13 UTC
The bug is a client side but, however I'm sure they don't use scp ;-)


Note You need to log in before you can comment on or make changes to this bug.