Bug 1816324 (CVE-2019-15058) - CVE-2019-15058 stbi: heap-based buffer overflow in stbi__tga_load function in stb_image.h
Summary: CVE-2019-15058 stbi: heap-based buffer overflow in stbi__tga_load function in...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2019-15058
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1816326
Blocks: 1816325
TreeView+ depends on / blocked
 
Reported: 2020-03-23 19:20 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-02-16 20:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-30 10:31:45 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-03-23 19:20:38 UTC
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in
stbi__tga_load, leading to Information Disclosure or Denial of Service.

Reference:
https://github.com/nothings/stb/issues/790

Comment 1 Guilherme de Almeida Suckevicz 2020-03-23 19:28:45 UTC
Created stbi tracking bugs for this issue:

Affects: fedora-all [bug 1816326]

Comment 4 Product Security DevOps Team 2020-04-30 10:31:45 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-15058

Comment 5 Huzaifa S. Sidhpurwala 2020-05-06 08:24:43 UTC
Statement:

The versions of stbi embedded in Red Hat products do not contain the vulnerable code and therefore they are not affected by this flaw.


Note You need to log in before you can comment on or make changes to this bug.