Bug 1780995 (CVE-2019-1551) - CVE-2019-1551 openssl: Integer overflow in RSAZ modular exponentiation on x86_64
Summary: CVE-2019-1551 openssl: Integer overflow in RSAZ modular exponentiation on x86_64
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-1551
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1781004 1781005 1781006 1781013 1781014 1781015
Blocks: 1780996
TreeView+ depends on / blocked
 
Reported: 2019-12-09 03:55 UTC by Huzaifa S. Sidhpurwala
Modified: 2021-02-16 20:56 UTC (History)
47 users (show)

Fixed In Version: openssl 1.1.1e
Doc Type: If docs needed, set a value
Doc Text:
An integer overflow was found in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. As per upstream: * No EC algorithms are affected. * Attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. * Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. * Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME
Clone Of:
Environment:
Last Closed: 2020-10-28 20:21:15 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:4383 0 None None None 2020-10-28 15:49:41 UTC
Red Hat Product Errata RHSA-2020:4384 0 None None None 2020-10-28 16:00:52 UTC
Red Hat Product Errata RHSA-2020:4514 0 None None None 2020-11-04 01:38:03 UTC

Description Huzaifa S. Sidhpurwala 2019-12-09 03:55:08 UTC
As per openssl upstream advisory:

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME.

OpenSSL versions 1.1.1 and 1.0.2 are affected by this issue. However due to the low severity of this issue we are not creating new releases at this time. The 1.1.1 mitigation for this issue can be found in commit 419102400. The 1.0.2 mitigation for this issue can be found in commit f1c5eea8a.

Comment 1 Huzaifa S. Sidhpurwala 2019-12-09 03:57:26 UTC
External References:

https://www.openssl.org/news/secadv/20191206.txt
https://github.com/openssl/openssl/pull/10575

Comment 3 Huzaifa S. Sidhpurwala 2019-12-09 04:53:30 UTC
Created mingw-openssl tracking bugs for this issue:

Affects: epel-7 [bug 1781006]
Affects: fedora-all [bug 1781005]


Created openssl tracking bugs for this issue:

Affects: fedora-all [bug 1781004]

Comment 4 Huzaifa S. Sidhpurwala 2019-12-09 05:29:20 UTC
Statement:

Accelerated modular exponentiation for Intel processors (RSAZ) was introduced in openssl-1.0.2, therefore older versions of OpenSSL are not affected by this flaw.

Comment 6 Ted Jongseok Won 2019-12-11 01:21:11 UTC
This vulnerability is out of security support scope for the following products:
 * Red Hat JBoss Enterprise Application Platform 6
 * Red Hat JBoss Enterprise Web Server 2

Please refer to https://access.redhat.com/support/policy/updates/jboss_notes for more details.

Comment 7 Laurie Morse 2020-01-23 19:24:51 UTC
We use Red Hat Enterprise Linux 8 (RHEL8) specifically we use container images ubi8/ubi-minimal.  When we install openssl we get version 1.1.1c and apparently the fix is in 1.1.1e.
We also use Red Hat Enterprise Linux 7 (RHEL7) as container image ubi7/ubi-minimal.  When we install openssl we get version 1.0.2k and the fix is in 1.0.2u.

It is stated that RHEL8 is "affected" by CVE-2019-1551 - https://access.redhat.com/security/cve/cve-2019-1551
It is also stated that RHEL7 is "Will not fix".

Will RHEL8 be fixed by this bugzilla ticket?  When can we expect this fix?  Do I need to open another bugzilla ticket?
Will RHEL7 never be fixed?

Comment 9 Tomas Mraz 2020-01-30 08:54:04 UTC
RHEL-7:

512 bit DH is already disabled. As this bug is about leakage of the private key to the attacker, it should be fully sufficient to just not use 1024 bit RSA keys or 1024 bit DSA keys. These keys are not secure enough anyway. 3-prime RSA keys are not supported on RHEL-7.

RHEL-8:

The DEFAULT crypto policy already disables all these key sizes.

Comment 10 Laurie Morse 2020-03-04 21:02:25 UTC
This keeps coming up with our services teams needing the fixed versions of OpenSSL.  There are several CVEs that are involved ...
CVE-2019-1547 - Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).
CVE-2019-1549 - Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c).
CVE-2019-1551 - Fixed in OpenSSL 1.1.1e-dev (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u-dev (Affected 1.0.2-1.0.2t).
CVE-2019-1563 - Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

Our images installed with OpenSSL show the following ...
Based on registry.access.redhat.com/ubi7/ubi-minimal - Need OpenSSL 1.0.2t or 1.0.2u-dev in ubi-7/x86_64 Red Hat Universal Base Image 7 Server (RPMs)
[root@4c866ac08b81 /]# openssl version
OpenSSL 1.0.2k-fips  26 Jan 2017
Based on registry.access.redhat.com/ubi8/ubi-minimal - Need OpenSSL 1.1.1d or 1.1.1e-dev in ubi-8-baseos Red Hat Universal Base Image 8 (RPMs) - BaseOS
[root@6ad506124398 /]# openssl version
OpenSSL 1.1.1c FIPS  28 May 2019

Having these upgrades will solve a lot of these issues for us.  When can we expect the OpenSSL packages upgraded?

Comment 13 Huzaifa S. Sidhpurwala 2020-03-23 03:28:47 UTC
Mitigation:

For Red Hat Enterprise Linux 7, 512 bit DH is already disabled. As this bug is about leakage of the private key to the attacker, it should be fully sufficient to just not use 1024 bit RSA keys or 1024 bit DSA keys. These keys are not secure enough anyway. 3-prime RSA keys are not supported on RHEL-7.

For Red Hat Enterprise 8, The DEFAULT crypto policy already disables all these key sizes.

Also applications compiled with openssl which use the low level  API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME, other users of this API are not affected by this flaw.

Comment 14 Laurie Morse 2020-03-23 16:00:24 UTC
There are many teams needing to use these images and are reporting these vulnerabilities.  They require the upgraded images.  When can we expect the OpenSSL packages upgraded?

Comment 15 errata-xmlrpc 2020-10-28 15:49:54 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Core Services

Via RHSA-2020:4383 https://access.redhat.com/errata/RHSA-2020:4383

Comment 16 errata-xmlrpc 2020-10-28 16:00:47 UTC
This issue has been addressed in the following products:

  JBoss Core Services on RHEL 7
  JBoss Core Services on RHEL 6

Via RHSA-2020:4384 https://access.redhat.com/errata/RHSA-2020:4384

Comment 17 Product Security DevOps Team 2020-10-28 20:21:15 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-1551

Comment 18 errata-xmlrpc 2020-11-04 01:37:59 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2020:4514 https://access.redhat.com/errata/RHSA-2020:4514


Note You need to log in before you can comment on or make changes to this bug.