Bug 1776447 (CVE-2019-16222) - CVE-2019-16222 wordpress: URL sanitization that can lead to XSS
Summary: CVE-2019-16222 wordpress: URL sanitization that can lead to XSS
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-16222
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1776448 1776449
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-25 17:01 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-27 10:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-27 10:50:53 UTC
Embargoed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2019-11-25 17:01:46 UTC
WordPress before 5.2.3 has an issue with URL sanitization in wp_kses_bad_protocol_once in wp-includes/kses.php that can lead to cross-site scripting (XSS) attacks.

Reference:
https://wpvulndb.com/vulnerabilities/9867

Upstream commit:
https://github.com/WordPress/WordPress/commit/30ac67579559fe42251b5a9f887211bf61a8ed68

Comment 1 Guilherme de Almeida Suckevicz 2019-11-25 17:02:19 UTC
Created wordpress tracking bugs for this issue:

Affects: epel-6 [bug 1776448]
Affects: epel-7 [bug 1776449]


Note You need to log in before you can comment on or make changes to this bug.