Bug 1819663 (CVE-2019-16541) - CVE-2019-16541 jenkins-jira-plugin: plugin information disclosure
Summary: CVE-2019-16541 jenkins-jira-plugin: plugin information disclosure
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-16541
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1820005 1820006
Blocks: 1819705
TreeView+ depends on / blocked
 
Reported: 2020-04-01 09:34 UTC by Dhananjay Arunesh
Modified: 2021-02-16 20:20 UTC (History)
10 users (show)

Fixed In Version: jenkins-jira-plugin 3.0.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-27 13:17:34 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:3541 0 None None None 2020-08-26 22:46:55 UTC
Red Hat Product Errata RHSA-2020:4297 0 None None None 2020-10-27 14:54:00 UTC

Description Dhananjay Arunesh 2020-04-01 09:34:27 UTC
Jenkins JIRA Plugin 3.0.10 and earlier does not declare the correct (folder) scope for per-folder Jira site definitions, allowing users to select and use credentials with System scope.

Reference:
http://www.openwall.com/lists/oss-security/2019/11/21/1

Comment 1 Sam Fowler 2020-04-02 03:49:46 UTC
External References:

https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1106

Comment 4 errata-xmlrpc 2020-08-26 22:46:53 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2020:3541 https://access.redhat.com/errata/RHSA-2020:3541

Comment 5 Product Security DevOps Team 2020-08-27 13:17:34 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-16541

Comment 6 errata-xmlrpc 2020-10-27 14:53:58 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.6

Via RHSA-2020:4297 https://access.redhat.com/errata/RHSA-2020:4297


Note You need to log in before you can comment on or make changes to this bug.