Bug 1776961 (CVE-2019-17670) - CVE-2019-17670 wordpress: Server-side request forgery vulnerability because Windows paths are mishandled during certain validation of relative URLs
Summary: CVE-2019-17670 wordpress: Server-side request forgery vulnerability because W...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2019-17670
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1776963 1776964 1776965
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-26 16:28 UTC by Guilherme de Almeida Suckevicz
Modified: 2020-04-29 13:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-26 19:05:03 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2019-11-26 16:28:22 UTC
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.

Reference:
https://wpvulndb.com/vulnerabilities/9912

Upstream commit:
https://github.com/WordPress/WordPress/commit/9db44754b9e4044690a6c32fd74b9d5fe26b07b2

Comment 1 Guilherme de Almeida Suckevicz 2019-11-26 16:29:07 UTC
Created wordpress tracking bugs for this issue:

Affects: epel-6 [bug 1776964]
Affects: epel-7 [bug 1776965]
Affects: fedora-all [bug 1776963]

Comment 2 Product Security DevOps Team 2019-11-26 19:05:03 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.