Bug 1765589 (CVE-2019-18391) - CVE-2019-18391 virglrenderer: heap based buffer overflow in the vrend_renderer_transfer_write_iov function
Summary: CVE-2019-18391 virglrenderer: heap based buffer overflow in the vrend_rendere...
Keywords:
Status: NEW
Alias: CVE-2019-18391
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1784712 1784713
Blocks: 1765598
TreeView+ depends on / blocked
 
Reported: 2019-10-25 14:04 UTC by Marian Rehak
Modified: 2019-12-18 06:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Marian Rehak 2019-10-25 14:04:47 UTC
A heap-based buffer overflow in the vrend_renderer_transfer_write_iov function in vrend_renderer.c in virglrenderer through 0.8.0 allows guest OS users to cause a denial of service via VIRGL_CCMD_RESOURCE_INLINE_WRITE commands.

Upstream Issue:

https://gitlab.freedesktop.org/virgl/virglrenderer/merge_requests/314/diffs?commit_id=8c9cfb4e425542e96f0717189fe4658555baaf08

Comment 3 Prasad J Pandit 2019-12-18 06:53:41 UTC
Created virglrenderer tracking bugs for this issue:

Affects: fedora-all [bug 1784712]


Note You need to log in before you can comment on or make changes to this bug.