Bug 1786646 (CVE-2019-18609) - CVE-2019-18609 librabbitmq: integer overflow in amqp_handle_input in amqp_connection.c leads to heap-based buffer overflow
Summary: CVE-2019-18609 librabbitmq: integer overflow in amqp_handle_input in amqp_con...
Keywords:
Status: NEW
Alias: CVE-2019-18609
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1786647
Blocks: 1786648
TreeView+ depends on / blocked
 
Reported: 2019-12-26 18:38 UTC by Guilherme de Almeida Suckevicz
Modified: 2020-01-15 20:51 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2019-12-26 18:38:54 UTC
An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corruption in the handling of CONNECTION_STATE_HEADER. A rogue server could return a malicious frame header that leads to a smaller target_size value than needed. This condition is then carried on to a memcpy function that copies too much data into a heap buffer.

Reference and upstream commit:
https://github.com/alanxz/rabbitmq-c/commit/fc85be7123050b91b054e45b91c78d3241a5047a

Comment 1 Guilherme de Almeida Suckevicz 2019-12-26 18:39:09 UTC
Created librabbitmq tracking bugs for this issue:

Affects: epel-6 [bug 1786647]


Note You need to log in before you can comment on or make changes to this bug.