Bug 1777584 (CVE-2019-19330) - CVE-2019-19330 haproxy: HTTP/2 implementation vulnerable to intermediary encapsulation attacks
Summary: CVE-2019-19330 haproxy: HTTP/2 implementation vulnerable to intermediary enca...
Keywords:
Status: NEW
Alias: CVE-2019-19330
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1779022 1779023 1781027 1788780 1777585 1781028 1781029 1781030
Blocks: 1777586
TreeView+ depends on / blocked
 
Reported: 2019-11-27 21:39 UTC by Pedro Sampaio
Modified: 2020-01-08 05:00 UTC (History)
13 users (show)

Fixed In Version: haproxy 2.0.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Pedro Sampaio 2019-11-27 21:39:24 UTC
The HTTP/2 implementation in HAProxy before 2.0.10 mishandles headers, as demonstrated by carriage return (CR, ASCII 0xd), line feed (LF, ASCII 0xa), and the zero character (NUL, ASCII 0x0), aka Intermediary Encapsulation Attacks.

Upstream patch:

https://git.haproxy.org/?p=haproxy.git;a=commit;h=54f53ef7ce4102be596130b44c768d1818570344
https://git.haproxy.org/?p=haproxy.git;a=commit;h=146f53ae7e97dbfe496d0445c2802dd0a30b0878
https://git.haproxy.org/?p=haproxy-2.0.git;a=commit;h=ac198b92d461515551b95daae20954b3053ce87e

Comment 1 Pedro Sampaio 2019-11-27 21:39:45 UTC
Created haproxy tracking bugs for this issue:

Affects: fedora-all [bug 1777585]

Comment 6 Sam Fowler 2019-12-11 04:25:32 UTC
Statement:

Support for HTTP/2 protocol was added to haproxy in version 1.8, therefore previous versions are not affected by this flaw.

The version of haproxy shipped in OpenShift Container Platform 4 contains the vulnerable code, however exploitation requires setting ROUTER_USE_HTTP2 in the OpenShift Ingress Operator, which is not currently possible. The impact of this vulnerability is therefore reduced in OpenShift Container Platform 4 to Low.


Note You need to log in before you can comment on or make changes to this bug.