Bug 1819133 (CVE-2019-2182) - CVE-2019-2182 kernel: possible execution path in MMU code leads to local escalation of privilege
Summary: CVE-2019-2182 kernel: possible execution path in MMU code leads to local esca...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2019-2182
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1819134 1826751 1826752
Blocks: 1750356 1819135
TreeView+ depends on / blocked
 
Reported: 2020-03-31 09:52 UTC by msiddiqu
Modified: 2021-02-16 20:22 UTC (History)
46 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in MMU code in the Linux kernel. An execution path leaving some kernel text and rodata pages writable leading to local escalation of privilege. User interaction is not needed for this exploitation.
Clone Of:
Environment:
Last Closed: 2020-04-28 16:09:57 UTC
Embargoed:


Attachments (Terms of Use)

Description msiddiqu 2020-03-31 09:52:35 UTC
A vulnerability was found in MMU code in kernel where there is a possible execution path leaving some kernel text and rodata pages writable. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

Upstream commit:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=15122ee2c515a253b0c66a3e618bc7ebe35105eb

References:
https://source.android.com/security/bulletin/pixel/2019-09-01

Comment 1 msiddiqu 2020-03-31 09:53:48 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1819134]

Comment 2 Justin M. Forbes 2020-03-31 13:54:06 UTC
This was fixed for Fedora with the 4.16 stable kernel rebases.

Comment 8 Alex 2020-04-22 13:44:54 UTC
Mitigation:

Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.


Note You need to log in before you can comment on or make changes to this bug.