Bug 1669151 (CVE-2019-3807) - CVE-2019-3807 pdns-recursor: Insufficient validation of DNSSEC signature
Summary: CVE-2019-3807 pdns-recursor: Insufficient validation of DNSSEC signature
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2019-3807
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20190121,reported=2...
Depends On: 1669422 1669423
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 13:21 UTC by Dhananjay Arunesh
Modified: 2019-06-10 10:46 UTC (History)
2 users (show)

Fixed In Version: pdns-recursor 4.1.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:46:34 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2019-01-24 13:21:04 UTC
An issue has been found in PowerDNS Recursor where records in the answer section of responses received from authoritative servers with the AA flag not set were not properly validated, allowing an attacker to bypass DNSSEC validation.

Reference:
https://docs.powerdns.com/recursor/security-advisories/powerdns-advisory-2019-02.html

Comment 1 Dhananjay Arunesh 2019-01-25 08:26:05 UTC
Created pdns-recursor tracking bugs for this issue:

Affects: fedora-all [bug 1669422]

Comment 2 Dhananjay Arunesh 2019-01-25 08:26:30 UTC
Created pdns-recursor tracking bugs for this issue:

Affects: epel-all [bug 1669423]

Comment 3 Product Security DevOps Team 2019-06-10 10:46:34 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.