Bug 1668067 (CVE-2019-3809) - CVE-2019-3809 moodle: Blind SSRF Risk in /badges/mybackpack.php (MSA-19-0002)
Summary: CVE-2019-3809 moodle: Blind SSRF Risk in /badges/mybackpack.php (MSA-19-0002)
Status: NEW
Alias: CVE-2019-3809
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20190121,repor...
Keywords: Security
Depends On: 1668068
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-21 20:33 UTC by Laura Pardo
Modified: 2019-06-08 23:49 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Laura Pardo 2019-01-21 20:33:28 UTC
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.


References:
https://moodle.org/mod/forum/discuss.php?d=381229#p1536766

Upstream Patch:
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-64222

Comment 1 Laura Pardo 2019-01-21 20:33:43 UTC
Created moodle tracking bugs for this issue:

Affects: epel-all [bug 1668068]


Note You need to log in before you can comment on or make changes to this bug.