Bug 1688508 (CVE-2019-3869) - CVE-2019-3869 Tower: credentials leaked through environment variables
Summary: CVE-2019-3869 Tower: credentials leaked through environment variables
Status: CLOSED ERRATA
Alias: CVE-2019-3869
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20190326,repor...
Keywords: Security
Depends On: 1688509 1723666
Blocks: 1688165
TreeView+ depends on / blocked
 
Reported: 2019-03-13 21:19 UTC by Borja Tarraso
Modified: 2019-06-25 06:21 UTC (History)
15 users (show)

(edit)
When running Tower on OpenShift or Kubernetes, application credentials are exposed to playbook job runs via environment variables. A malicious user with the ability to write playbooks could use this to gain administrative privileges.
Clone Of:
(edit)
Last Closed: 2019-03-27 15:53:45 UTC


Attachments (Terms of Use)

Description Borja Tarraso 2019-03-13 21:19:35 UTC
When running Tower on OpenShift or Kubernetes, application credentials are exposed to playbook job runs via environment variables. A malicious user with the ability to write playbooks could use this to gain administrative privileges.

Comment 3 Borja Tarraso 2019-03-13 22:17:35 UTC
Acknowledgments:

Name: Chris Bertsch (FactSet Research Systems Inc)

Comment 4 Borja Tarraso 2019-03-26 19:30:36 UTC
External References:

https://github.com/ansible/awx/pull/3505


Note You need to log in before you can comment on or make changes to this bug.