Bug 1679948 (CVE-2019-6340) - CVE-2019-6340 drupal: does not sanitize data from non-form sources leads to arbitrary PHP code execution
Summary: CVE-2019-6340 drupal: does not sanitize data from non-form sources leads to a...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2019-6340
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1679949
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-22 10:18 UTC by Dhananjay Arunesh
Modified: 2021-02-05 19:10 UTC (History)
3 users (show)

Fixed In Version: drupal 8.6.10, drupal 8.5.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:48:44 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2019-02-22 10:18:08 UTC
Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7.

Reference:
https://www.drupal.org/sa-core-2019-003

Comment 1 Dhananjay Arunesh 2019-02-22 10:23:53 UTC
Created drupal tracking bugs for this issue:

Affects: fedora-all [bug 1679949]

Comment 2 Product Security DevOps Team 2019-06-10 10:48:44 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.