Bug 1690312 (CVE-2019-9187) - CVE-2019-9187 ikiwiki: server-side request forgery resulting in dos
Summary: CVE-2019-9187 ikiwiki: server-side request forgery resulting in dos
Status: NEW
Alias: CVE-2019-9187
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20190228,repor...
Keywords: Security
Depends On: 1690314
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-19 09:39 UTC by Dhananjay Arunesh
Modified: 2019-06-08 23:55 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Dhananjay Arunesh 2019-03-19 09:39:05 UTC
The vulnerability was discovered in aggregate plugin of the Ikiwiki wiki compiler was susceptible to server-side request forgery, resulting in information disclosure or denial of service.

Reference:
https://www.openwall.com/lists/oss-security/2019/02/28/1

Upstream commit:
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=e7b0d4a
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=67543ce
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=d283e4c
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=9a275b2

Comment 1 Dhananjay Arunesh 2019-03-19 09:39:17 UTC
Created ikiwiki tracking bugs for this issue:

Affects: epel-6 [bug 1690314]

Comment 2 Dhananjay Arunesh 2019-03-19 09:40:05 UTC
External References:

https://www.debian.org/security/2019/dsa-4399


Note You need to log in before you can comment on or make changes to this bug.