Bug 1854843 (CVE-2020-11098) - CVE-2020-11098 freerdp: out-of-bound read in glyph_cache_put
Summary: CVE-2020-11098 freerdp: out-of-bound read in glyph_cache_put
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-11098
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1854845 1854844 1855864 1855865
Blocks: 1854906
TreeView+ depends on / blocked
 
Reported: 2020-07-08 11:07 UTC by Dhananjay Arunesh
Modified: 2021-05-18 20:34 UTC (History)
4 users (show)

Fixed In Version: freerdp 2.1.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-18 20:34:03 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2020-07-08 11:07:57 UTC
In FreeRDP before version 2.1.2, there is an out-of-bound read in glyph_cache_put. This affects all FreeRDP clients with `+glyph-cache` option enabled This is fixed in version 2.1.2.

References:
http://www.freerdp.com/2020/06/22/2_1_2-released
https://github.com/FreeRDP/FreeRDP/commit/c0fd449ec0870b050d350d6d844b1ea6dad4bc7d
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-jr57-f58x-hjmv

Comment 1 Dhananjay Arunesh 2020-07-08 11:10:11 UTC
Created freerdp tracking bugs for this issue:

Affects: epel-all [bug 1854845]
Affects: fedora-all [bug 1854844]

Comment 3 Todd Cullum 2020-07-10 18:06:13 UTC
glyph_cache_put() in libfreerdp/cache/glyph.c has an off-by-one indexing error which allows glyphCache->glyphCache[id].entries[index] to be indexed out-of-bounds. The patch ensures that index is less than glyphCache->glyphCache[id].number which avoids the out-of-bounds read. Marking this as Low because the feature is disabled by default and there is a low risk to availability in the freerdp client only.

Comment 4 Todd Cullum 2020-07-10 18:15:48 UTC
Mitigation:

Do not use the +glyph_cache option in the freerdp client, which is disabled by default in freerdp-2.0.0.rc4 (shipped with Red Hat Enterprise Linux 7 and 8), but required to connect to xrdp.

Comment 6 errata-xmlrpc 2021-05-18 15:34:08 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:1849 https://access.redhat.com/errata/RHSA-2021:1849

Comment 7 Product Security DevOps Team 2021-05-18 20:34:03 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-11098


Note You need to log in before you can comment on or make changes to this bug.