Bug 1911286 (CVE-2020-35269) - CVE-2020-35269 nagios: site-wide Cross Site Request Forgery
Summary: CVE-2020-35269 nagios: site-wide Cross Site Request Forgery
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2020-35269
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1924674 1924673
Blocks: 1911287
TreeView+ depends on / blocked
 
Reported: 2020-12-28 15:10 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-06-15 15:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Nagios Core application, where it is vulnerable to Site-Wide Cross-Site Request Forgery (CSRF) in many functions, such as adding – deleting for hosts or servers. The vulnerability is due to insufficient CSRF protections for the web UI on an affected version. This flaw allows an attacker to persuade a user of the interface to follow a malicious link. A successful exploit allows the attacker to perform arbitrary actions with the privilege level of the affected user. The highest threat from this vulnerability is to confidentiality, integrity, as well a system availability.
Clone Of:
Environment:
Last Closed: 2021-01-05 06:27:38 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-12-28 15:10:08 UTC
Nagios Core application version 4.2.4 is vulnerable to Site-Wide Cross-Site Request Forgery (CSRF) in many functions, like adding – deleting for hosts or servers. The vulnerability is due to insufficient CSRF protections for the web UI on an affected version. An attacker could exploit this vulnerability by persuading a user of the interface to follow a malicious link. A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user.

References:
https://gist.github.com/MoSalah20/d1d40b43eafba0bd22ee4cddecad3cbc
https://github.com/NagiosEnterprises/nagioscore/issues/809

Comment 2 Product Security DevOps Team 2021-01-05 06:27:38 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-35269

Comment 3 Hardik Vyas 2021-01-06 03:57:06 UTC
Statement:

Red Hat Gluster Storage (RHGS) 3.5 no longer support monitoring using Nagios. Red Hat Gluster Storage Web Administration is now the recommended monitoring tool for Red Hat Storage Gluster clusters, hence the nagios package provided by RHGS will not be fixed.

Comment 4 Hardik Vyas 2021-02-03 12:34:27 UTC
Created nagios tracking bugs for this issue:

Affects: epel-all [bug 1924674]
Affects: fedora-all [bug 1924673]


Note You need to log in before you can comment on or make changes to this bug.