Bug 1909227 (CVE-2020-35474) - CVE-2020-35474 mediawiki: message recentchanges-legend-watchlistexpiry can contain raw html
Summary: CVE-2020-35474 mediawiki: message recentchanges-legend-watchlistexpiry can co...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2020-35474
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1909228 1910209
Blocks: 1909242
TreeView+ depends on / blocked
 
Reported: 2020-12-18 16:52 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 02:58 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.11, mediawiki 1.35.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-28 02:58:47 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-12-18 16:52:46 UTC
In MediaWiki before 1.35.1, the combination of Html::rawElement and Message::text leads to XSS because the definition of MediaWiki:recentchanges-legend-watchlistexpiry can be changed onwiki so that the output is raw HTML.

References:
https://phabricator.wikimedia.org/T268894
https://lists.wikimedia.org/pipermail/mediawiki-announce/2020-December/000268.html

Comment 1 Guilherme de Almeida Suckevicz 2020-12-18 16:53:02 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1909228]


Note You need to log in before you can comment on or make changes to this bug.