Bug 1909224 (CVE-2020-35475) - CVE-2020-35475 mediawiki: messages userrights-expiry-current and userrights-expiry-none can contain raw html
Summary: CVE-2020-35475 mediawiki: messages userrights-expiry-current and userrights-e...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2020-35475
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1909225 1910209
Blocks: 1909242
TreeView+ depends on / blocked
 
Reported: 2020-12-18 16:50 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 02:58 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.11, mediawiki 1.35.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-28 02:58:39 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-12-18 16:50:21 UTC
In MediaWiki before 1.35.1, the messages userrights-expiry-current and userrights-expiry-none can contain raw HTML. XSS can happen when a user visits Special:UserRights but does not have rights to change all userrights, and the table on the left side has unchangeable groups in it. (The right column with the changeable groups is not affected and is escaped correctly.)

References:
https://phabricator.wikimedia.org/T268917
https://lists.wikimedia.org/pipermail/mediawiki-announce/2020-December/000268.html

Comment 1 Guilherme de Almeida Suckevicz 2020-12-18 16:50:36 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1909225]


Note You need to log in before you can comment on or make changes to this bug.