Bug 1798671 (CVE-2020-7045) - CVE-2020-7045 wireshark: invalid memory access in BT ATT dissector
Summary: CVE-2020-7045 wireshark: invalid memory access in BT ATT dissector
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2020-7045
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1801819
Blocks: 1796462
TreeView+ depends on / blocked
 
Reported: 2020-02-05 18:49 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-06-29 20:27 UTC (History)
9 users (show)

Fixed In Version: wireshark 3.0.8
Doc Type: If docs needed, set a value
Doc Text:
An invalid memory access vulnerability was discovered in Wireshark when processing malformed Bluetooth packets. An attacker could use this flaw to send malicious Bluetooth packets that can crash Wireshark, or trick a user into running the tool on a malformed packet trace file.
Clone Of:
Environment:
Last Closed: 2021-06-29 20:27:01 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-02-05 18:49:52 UTC
In Wireshark 3.0.x before 3.0.8, the BT ATT dissector could crash. This was addressed in epan/dissectors/packet-btatt.c by validating opcodes.

References:
https://www.wireshark.org/security/wnpa-sec-2020-02.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=16258

Upstream commit:
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=01f261de41f4dd3233ef578e5c0ffb9c25c7d14d

Comment 1 Riccardo Schirone 2020-02-11 16:50:44 UTC
The vulnerability is in the dissect_btatt() function. The vulnerability was not present before the following commit, which added support for GATT level fields:
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=8ba3d6fbe668748097ce2dc4b8203a1c80b81be0

Comment 3 Riccardo Schirone 2020-02-11 16:58:19 UTC
Statement:

This issue did not affect the versions of wireshark as shipped with Red Hat Enterprise Linux 7 as they did not include the vulnerable code.


Note You need to log in before you can comment on or make changes to this bug.