Bug 1900842 (CVE-2020-7928) - CVE-2020-7928 mongodb: Read overrun and access of arbitrary memory in $arrayToObject
Summary: CVE-2020-7928 mongodb: Read overrun and access of arbitrary memory in $arrayT...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2020-7928
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1900843
Blocks: 1900872
TreeView+ depends on / blocked
 
Reported: 2020-11-23 20:28 UTC by Pedro Sampaio
Modified: 2021-02-13 00:06 UTC (History)
26 users (show)

Fixed In Version: mongodb 3.6.20, mongodb 4.0.20, mongodb 4.2.9, mongodb 4.4.1, mongodb 4.7.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-04 23:02:48 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2020-11-23 20:28:51 UTC
A user authorized to perform database queries may trigger a read overrun and access arbitrary memory by issuing specially crafted queries. This issue affects: MongoDB Inc. MongoDB Server v4.5 versions prior to 4.5.1; v4.4 versions prior to 4.4.1; v4.2 versions prior to 4.2.9; v4.0 versions prior to 4.0.20; v3.6 versions prior to 3.6.20.

Upstream bug:

https://jira.mongodb.org/browse/SERVER-49404

Comment 1 Pedro Sampaio 2020-11-23 20:29:34 UTC
Created mongodb tracking bugs for this issue:

Affects: epel-all [bug 1900843]

Comment 2 Riccardo Schirone 2020-11-30 17:07:36 UTC
Upstream patch:
https://github.com/mongodb/mongo/commit/1772b9a0393b55e6a280a35e8f0a1f75c014f301

Comment 3 Riccardo Schirone 2020-11-30 17:12:28 UTC
The flaw is in the ExpressionArrayToObject class. The version of mongodb as shipped in RHUI-3 does not contain that class, thus it is not affected by this flaw.

Comment 4 Yadnyawalk Tale 2020-11-30 17:35:21 UTC
Red Hat Satellite 6.6 onward does not ship the MongoDB package; however, the product consumes MongoDB from Red Hat Software Collections (RHSCL) for Red Hat Enterprise Linux. Satellite has no plans to update to a version of MongoDB released with a Server Side Public License (SSPL) which includes all versions released after October 16, 2018. Refer to this article for more information: https://access.redhat.com/articles/5767021

Comment 5 Product Security DevOps Team 2020-12-04 23:02:48 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-7928


Note You need to log in before you can comment on or make changes to this bug.