Bug 1879536 (CVE-2020-9894) - CVE-2020-9894 webkitgtk: Out-of-bounds read may lead to unexpected application termination or arbitrary code execution
Summary: CVE-2020-9894 webkitgtk: Out-of-bounds read may lead to unexpected applicatio...
Keywords:
Status: NEW
Alias: CVE-2020-9894
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1881724 1881722 1881723
Blocks: 1879543
TreeView+ depends on / blocked
 
Reported: 2020-09-16 13:42 UTC by Pedro Sampaio
Modified: 2020-09-22 23:33 UTC (History)
3 users (show)

Fixed In Version: webkitgtk 2.28.4
Doc Type: If docs needed, set a value
Doc Text:
An out-of-bounds read flaw was found in webkitgtk that affected WebKitGTK versions before 2.28.4 and WPE WebKit versions before 2.28.4. This flaw allows a remote attacker to cause unexpected application termination or arbitrary code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Pedro Sampaio 2020-09-16 13:42:50 UTC
An out-of-bounds read was found in webkitgtk. A remote attacker may be able to cause unexpected application termination or arbitrary code execution. Versions affected: WebKitGTK before 2.28.4 and WPE WebKit before 2.28.4.

Comment 1 Pedro Sampaio 2020-09-16 13:42:54 UTC
External References:

https://webkitgtk.org/security/WSA-2020-0007.html


Note You need to log in before you can comment on or make changes to this bug.