Bug 1944331 (CVE-2020-9947) - CVE-2020-9947 webkitgtk: use after free issue may lead to arbitrary code execution
Summary: CVE-2020-9947 webkitgtk: use after free issue may lead to arbitrary code exec...
Keywords:
Status: NEW
Alias: CVE-2020-9947
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1944332 1946467
Blocks: 1944354
TreeView+ depends on / blocked
 
Reported: 2021-03-29 18:34 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-04-20 14:31 UTC (History)
4 users (show)

Fixed In Version: webkitgtk 2.30.0
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in WebKitGTK and WPE WebKit in versions prior to 2.30.0. Processing maliciously crafted web content may lead to arbitrary code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-03-29 18:34:36 UTC
A flaw was found in WebKitGTK.

Impact: Processing maliciously crafted web content may lead to arbitrary code execution.
Description: A use after free issue was addressed with improved memory management.

Reference:
https://webkitgtk.org/security/WSA-2021-0002.html

Comment 1 Guilherme de Almeida Suckevicz 2021-03-29 18:34:53 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1944332]

Comment 2 Mauro Matteo Cascella 2021-04-06 08:19:29 UTC
External References:

https://webkitgtk.org/security/WSA-2021-0002.html


Note You need to log in before you can comment on or make changes to this bug.