Bug 1901216 (CVE-2020-9951) - CVE-2020-9951 webkitgtk: use-after-free may lead to arbitrary code execution
Summary: CVE-2020-9951 webkitgtk: use-after-free may lead to arbitrary code execution
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-9951
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1901217 1908477
Blocks: 1901223
TreeView+ depends on / blocked
 
Reported: 2020-11-24 18:29 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-08-30 14:52 UTC (History)
4 users (show)

Fixed In Version: webkitgtk 2.30.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-18 14:36:39 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-11-24 18:29:45 UTC
A flaw was found in WebKitGTK. An use after free issue was addressed with improved memory management. Processing maliciously crafted web content may lead to arbitrary code execution.

Reference:
https://webkitgtk.org/security/WSA-2020-0008.html

Comment 1 Guilherme de Almeida Suckevicz 2020-11-24 18:30:00 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1901217]

Comment 3 errata-xmlrpc 2021-05-18 13:26:59 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:1586 https://access.redhat.com/errata/RHSA-2021:1586

Comment 4 Product Security DevOps Team 2021-05-18 14:36:39 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-9951


Note You need to log in before you can comment on or make changes to this bug.