Bug 1986858 (CVE-2021-1825) - CVE-2021-1825 webkitgtk: Input validation issue leading to cross site scripting attack
Summary: CVE-2021-1825 webkitgtk: Input validation issue leading to cross site scripti...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-1825
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1908476 1986859
Blocks: 1986910
TreeView+ depends on / blocked
 
Reported: 2021-07-28 13:30 UTC by Michael Kaplan
Modified: 2021-08-31 18:56 UTC (History)
4 users (show)

Fixed In Version: webkitgtk 2.30.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-31 18:56:26 UTC


Attachments (Terms of Use)

Description Michael Kaplan 2021-07-28 13:30:51 UTC
An input validation issue was addressed with improved input validation.

Comment 1 Michael Kaplan 2021-07-28 13:31:27 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1986859]

Comment 2 Tomas Hoger 2021-08-30 14:46:55 UTC
Upstream advisory:

https://webkitgtk.org/security/WSA-2021-0004.html

Comment 3 Tomas Hoger 2021-08-31 12:31:14 UTC
According to the WebKitGTK upstream advisory, this issue was fixed upstream in version 2.30.0.  The  webkit2gtk3 packages in Red Hat Enterprise Linux 8 were previously updated to fixed upstream versions via the following erratum:

https://access.redhat.com/errata/RHSA-2021:1586

Comment 4 Product Security DevOps Team 2021-08-31 18:56:26 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-1825


Note You need to log in before you can comment on or make changes to this bug.