Bug 1944350 (CVE-2021-1870) - CVE-2021-1870 webkitgtk: Logic issue leading to arbitrary code execution
Summary: CVE-2021-1870 webkitgtk: Logic issue leading to arbitrary code execution
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-1870
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2079487 1944351 1946480 2069981 2079488 2079489
Blocks: 1944354
TreeView+ depends on / blocked
 
Reported: 2021-03-29 18:52 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-04-27 15:34 UTC (History)
5 users (show)

Fixed In Version: webkitgtk 2.30.6
Doc Type: If docs needed, set a value
Doc Text:
A logic issue was found in WebKitGTK and WPE WebKit in versions prior to 2.30.6. A remote attacker may be able to cause arbitrary code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-11-09 23:54:08 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:4381 0 None None None 2021-11-09 18:31:13 UTC

Description Guilherme de Almeida Suckevicz 2021-03-29 18:52:33 UTC
A flaw was found in WebKitGTK.

Impact: A remote attacker may be able to cause arbitrary code execution.
Description: A logic issue was addressed with improved restrictions.

Reference:
https://webkitgtk.org/security/WSA-2021-0002.html

Comment 1 Guilherme de Almeida Suckevicz 2021-03-29 18:52:52 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1944351]

Comment 2 Mauro Matteo Cascella 2021-04-06 08:36:35 UTC
External References:

https://webkitgtk.org/security/WSA-2021-0002.html

Comment 4 errata-xmlrpc 2021-11-09 18:31:11 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4381 https://access.redhat.com/errata/RHSA-2021:4381

Comment 5 Product Security DevOps Team 2021-11-09 23:54:07 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-1870


Note You need to log in before you can comment on or make changes to this bug.