Bug 1928736 (CVE-2021-20212) - CVE-2021-20212 privoxy: memory leak if multiple filters are executed and the last one is skipped due to a pcre error
Summary: CVE-2021-20212 privoxy: memory leak if multiple filters are executed and the ...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-20212
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1928737 1928738
Blocks: 1928926
TreeView+ depends on / blocked
 
Reported: 2021-02-15 13:22 UTC by msiddiqu
Modified: 2021-02-19 15:03 UTC (History)
3 users (show)

Fixed In Version: Privoxy 3.0.29
Doc Type: If docs needed, set a value
Doc Text:
Memory leak if multiple filters are executed and the last one is skipped due to a pcre error leading to a system crash.
Clone Of:
Environment:
Last Closed: 2021-02-15 16:09:54 UTC


Attachments (Terms of Use)

Description msiddiqu 2021-02-15 13:22:08 UTC
Memory leak if multiple filters are executed and the last one is skipped due to a pcre error

Upstream Patch:
 
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=5cfb7bc8fe

External References:

https://www.privoxy.org/3.0.29/user-manual/whatsnew.html

Comment 1 msiddiqu 2021-02-15 13:22:31 UTC
Created privoxy tracking bugs for this issue:

Affects: epel-all [bug 1928738]
Affects: fedora-all [bug 1928737]

Comment 2 Product Security DevOps Team 2021-02-15 16:09:54 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.