Bug 1923252 (CVE-2021-20217) - CVE-2021-20217 privoxy: Assertion failure triggered by a crafted CGI request
Summary: CVE-2021-20217 privoxy: Assertion failure triggered by a crafted CGI request
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-20217
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
: 1923105 (view as bug list)
Depends On: 1923253
Blocks: 1923104 1928902
TreeView+ depends on / blocked
 
Reported: 2021-02-01 15:53 UTC by Pedro Sampaio
Modified: 2021-02-15 19:38 UTC (History)
3 users (show)

Fixed In Version: privoxy 3.0.31
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Privoxy before version 3.0.31. An assertion failure triggered by a crafted CGI request may lead to denial of service. The highest threat from this vulnerability is to system availability.
Clone Of:
Environment:
Last Closed: 2021-02-01 20:42:05 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2021-02-01 15:53:23 UTC
A flaw was found in privoxy before version 3.0.31. An assertion failure triggered by a crafted CGI request may lead to denial of service.

References:

https://www.openwall.com/lists/oss-security/2021/01/31/2

Comment 1 Pedro Sampaio 2021-02-01 15:53:51 UTC
Created privoxy tracking bugs for this issue:

Affects: fedora-all [bug 1923253]

Comment 2 Pedro Sampaio 2021-02-01 16:00:30 UTC
*** Bug 1923105 has been marked as a duplicate of this bug. ***

Comment 3 Product Security DevOps Team 2021-02-01 20:42:05 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.