Bug 2096941 (CVE-2021-21252) - CVE-2021-21252 jquery-validate: jquery.validate.js vulnerable to ReDoS
Summary: CVE-2021-21252 jquery-validate: jquery.validate.js vulnerable to ReDoS
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2021-21252
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-14 15:25 UTC by Patrick Del Bello
Modified: 2022-06-15 12:15 UTC (History)
14 users (show)

Fixed In Version: jquery-validate 1.19.3
Doc Type: ---
Doc Text:
A flaw was found in jQuery-validate. There is an issue where it contains one or more regular expressions vulnerable to a Regular Expression Denial of Service (ReDoS).
Clone Of:
Environment:
Last Closed: 2022-06-14 19:50:16 UTC


Attachments (Terms of Use)

Description Patrick Del Bello 2022-06-14 15:25:09 UTC
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
https://github.com/jquery-validation/jquery-validation/pull/2371
https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
https://security.netapp.com/advisory/ntap-20210219-0005/
https://www.npmjs.com/package/jquery-validation

Comment 1 Product Security DevOps Team 2022-06-14 19:50:15 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-21252


Note You need to log in before you can comment on or make changes to this bug.