Bug 1925156 (CVE-2021-21607) - CVE-2021-21607 jenkins: Excessive memory allocation in graph URLs leads to denial of service
Summary: CVE-2021-21607 jenkins: Excessive memory allocation in graph URLs leads to d...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-21607
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1925482 1925483 1925484 1925485 1925486 1929919 1929921
Blocks: 1925147
TreeView+ depends on / blocked
 
Reported: 2021-02-04 13:54 UTC by Michael Kaplan
Modified: 2021-04-13 09:22 UTC (History)
23 users (show)

Fixed In Version: jenkins 2.275, jenkins LTS 2.263.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-18 19:02:37 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:0423 0 None None None 2021-02-17 19:04:59 UTC
Red Hat Product Errata RHSA-2021:0429 0 None None None 2021-03-03 04:17:57 UTC

Description Michael Kaplan 2021-02-04 13:54:06 UTC
Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not limit sizes provided as query parameters to graph-rendering URLs, allowing attackers to request crafted URLs that use all available memory in Jenkins, potentially leading to out of memory errors.

Comment 3 errata-xmlrpc 2021-02-17 19:04:56 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.6

Via RHSA-2021:0423 https://access.redhat.com/errata/RHSA-2021:0423

Comment 4 Product Security DevOps Team 2021-02-18 19:02:37 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-21607

Comment 5 errata-xmlrpc 2021-03-03 04:17:54 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.5

Via RHSA-2021:0429 https://access.redhat.com/errata/RHSA-2021:0429


Note You need to log in before you can comment on or make changes to this bug.