Bug 1932110 (CVE-2021-23968) - CVE-2021-23968 Mozilla: Content Security Policy violation report could have contained the destination of a redirect
Summary: CVE-2021-23968 Mozilla: Content Security Policy violation report could have c...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-23968
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1930750 1930751 1930752 1930753 1930754 1931640 1931641 1931642 1931643 1931644
Blocks: 1930748
TreeView+ depends on / blocked
 
Reported: 2021-02-24 01:19 UTC by Doran Moppert
Modified: 2021-10-05 06:55 UTC (History)
6 users (show)

Fixed In Version: firefox 78.8, thunderbird 78.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-24 19:02:47 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:0655 0 None None None 2021-02-24 15:00:09 UTC
Red Hat Product Errata RHSA-2021:0656 0 None None None 2021-02-24 15:41:08 UTC
Red Hat Product Errata RHSA-2021:0657 0 None None None 2021-02-24 15:31:17 UTC
Red Hat Product Errata RHSA-2021:0658 0 None None None 2021-02-24 15:32:25 UTC
Red Hat Product Errata RHSA-2021:0659 0 None None None 2021-02-24 15:30:26 UTC
Red Hat Product Errata RHSA-2021:0660 0 None None None 2021-02-24 15:40:26 UTC
Red Hat Product Errata RHSA-2021:0661 0 None None None 2021-02-24 15:58:54 UTC
Red Hat Product Errata RHSA-2021:0662 0 None None None 2021-02-24 15:46:11 UTC

Description Doran Moppert 2021-02-24 01:19:23 UTC
If Content Security Policy blocked frame navigation, the full destination of a redirect served in the frame was reported in the violation report; as opposed to the original frame URI. This could be used to leak sensitive information contained in such URIs.



External Reference:

https://www.mozilla.org/en-US/security/advisories/mfsa2021-08/#CVE-2021-23968

Comment 1 Doran Moppert 2021-02-24 01:19:28 UTC
Acknowledgments:

Name: the Mozilla project
Upstream: Ademar Nowasky Junior

Comment 2 errata-xmlrpc 2021-02-24 15:00:06 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:0655 https://access.redhat.com/errata/RHSA-2021:0655

Comment 3 errata-xmlrpc 2021-02-24 15:30:24 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:0659 https://access.redhat.com/errata/RHSA-2021:0659

Comment 4 errata-xmlrpc 2021-02-24 15:31:15 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:0657 https://access.redhat.com/errata/RHSA-2021:0657

Comment 5 errata-xmlrpc 2021-02-24 15:32:23 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:0658 https://access.redhat.com/errata/RHSA-2021:0658

Comment 6 errata-xmlrpc 2021-02-24 15:40:23 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:0660 https://access.redhat.com/errata/RHSA-2021:0660

Comment 7 errata-xmlrpc 2021-02-24 15:41:05 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:0656 https://access.redhat.com/errata/RHSA-2021:0656

Comment 8 errata-xmlrpc 2021-02-24 15:46:08 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:0662 https://access.redhat.com/errata/RHSA-2021:0662

Comment 9 errata-xmlrpc 2021-02-24 15:58:52 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:0661 https://access.redhat.com/errata/RHSA-2021:0661

Comment 10 Product Security DevOps Team 2021-02-24 19:02:47 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-23968


Note You need to log in before you can comment on or make changes to this bug.