Bug 2023408 (CVE-2021-27836) - CVE-2021-27836 libxls: a denial of service via a crafted XLS file
Summary: CVE-2021-27836 libxls: a denial of service via a crafted XLS file
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-27836
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2023409
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-15 16:08 UTC by Marian Rehak
Modified: 2021-11-15 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-15 16:31:18 UTC


Attachments (Terms of Use)

Description Marian Rehak 2021-11-15 16:08:36 UTC
An issue was discoverered in in function xls_getWorkSheet in xls.c in libxls 1.6.2, allows attackers to cause a denial of service, via a crafted XLS file.

Upstream Reference:

https://github.com/libxls/libxls/issues/94

Comment 1 Marian Rehak 2021-11-15 16:08:48 UTC
Created libxls tracking bugs for this issue:

Affects: fedora-all [bug 2023409]

Comment 2 Product Security DevOps Team 2021-11-15 16:31:16 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.