Bug 1949520 (CVE-2021-29262) - CVE-2021-29262 solr: misapplied Zookeeper ACLs can result in leakage of configured authentication and authorization settings
Summary: CVE-2021-29262 solr: misapplied Zookeeper ACLs can result in leakage of confi...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-29262
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1949524
TreeView+ depends on / blocked
 
Reported: 2021-04-14 13:22 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-05-05 20:33 UTC (History)
53 users (show)

Fixed In Version: Solr 8.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-05 20:33:57 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-04-14 13:22:19 UTC
When starting Apache Solr versions prior to 8.8.2, configured with the SaslZkACLProvider or VMParamsAllAndReadonlyDigestZkACLProvider and no existing security.json znode, if the optional read-only user is configured then Solr would not treat that node as a sensitive path and would allow it to be readable. Additionally, with any ZkACLProvider, if the security.json is already present, Solr will not automatically update the ACLs.

Reference:
https://lists.apache.org/thread.html/r536da4c4e4e406f7843461cc754a3d0a3fe575aa576e2b71a9cd57d0%40%3Cannounce.apache.org%3E

Comment 5 Product Security DevOps Team 2021-05-05 20:33:57 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-29262


Note You need to log in before you can comment on or make changes to this bug.