Bug 1944700 (CVE-2021-29266) - CVE-2021-29266 kernel: use-after-free in drivers/vhost/vdpa.c because v->config_ctx has an invalid value upon re-opening a character device
Summary: CVE-2021-29266 kernel: use-after-free in drivers/vhost/vdpa.c because v->conf...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2021-29266
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1944701
Blocks: 1944703
TreeView+ depends on / blocked
 
Reported: 2021-03-30 14:01 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-04-05 08:24 UTC (History)
44 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Linux kernel. An invalid value upon reopening a character device can cause a use-after-free memory corruption. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-04-01 16:19:39 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-03-30 14:01:52 UTC
An issue was discovered in the Linux kernel before 5.11.9. drivers/vhost/vdpa.c has a use-after-free because v->config_ctx has an invalid value upon re-opening a character device.

Reference and upstream patch:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=f6bbf0010ba004f5e90c7aefdebc0ee4bd3283b9

Comment 1 Justin M. Forbes 2021-03-30 16:23:52 UTC
This was fixed for Fedora with the 5.11.9 stable kernel updates.


Note You need to log in before you can comment on or make changes to this bug.