Bug 2044969 (CVE-2021-29454) - CVE-2021-29454 php-Smarty: template authors could run arbitrary PHP code by crafting a malicious math string
Summary: CVE-2021-29454 php-Smarty: template authors could run arbitrary PHP code by c...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-29454
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2044970 2044971
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-25 11:50 UTC by Marian Rehak
Modified: 2022-01-25 12:30 UTC (History)
2 users (show)

Fixed In Version: php-Smarty 3.1.42, php-Smarty 4.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-25 12:30:43 UTC


Attachments (Terms of Use)

Description Marian Rehak 2022-01-25 11:50:20 UTC
Template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string.

Reference:

https://github.com/smarty-php/smarty/security/advisories/GHSA-29gp-2c3m-3j6m

Comment 1 Marian Rehak 2022-01-25 11:50:41 UTC
Created php-Smarty tracking bugs for this issue:

Affects: epel-7 [bug 2044971]
Affects: fedora-all [bug 2044970]

Comment 2 Product Security DevOps Team 2022-01-25 12:30:41 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.